Installing MailCheck

Install GMX MailCheck for your browser. Use different functions and always get an overview over your e-mails at a glance.

Requirements:

GMX MailCheck is compatible with Firefox in version 25 or later. We recommend that you use the latest version of Mozilla Firefox.

  1. Get GMX MailCheck on our Download Site
  2. Click on Free Download.
  3. Depending on your security settings, Firefox will ask for your permission before installation - click Allow and then Install now.
  4. Click Restart now.
Firefox will be restarted. Afterwards, you can log in to MailCheck.